using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)\b(\d+) ?m(?:m|illions?)?\b";
string substitution = @"\1000000";
string input = @"I need $ 150000000, or 150 million,1 millions, 15 Million, 15million, 15Million, 15 m, 15 M, 15m, 15M, 15 MM, 15MM, 5 thousand";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}