// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)\b(\d+) ?m(?:m|illions?)?\b").unwrap();
let string = "I need $ 150000000, or 150 million,1 millions, 15 Million, 15million, 15Million, 15 m, 15 M, 15m, 15M, 15 MM, 15MM, 5 thousand";
let substitution = "\\1000000";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}