use strict;
my $str = 'I need $ 150000000, or 150 million,1 millions, 15 Million, 15million, 15Million, 15 m, 15 M, 15m, 15M, 15 MM, 15MM, 5 thousand';
my $regex = qr/(?i)\b(\d+) ?m(?:m|illions?)?\b/p;
my $subst = '\\1000000';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";