re = /(?i)\b(\d+) ?m(?:m|illions?)?\b/
str = 'I need $ 150000000, or 150 million,1 millions, 15 Million, 15million, 15Million, 15 m, 15 M, 15m, 15M, 15 MM, 15MM, 5 thousand'
subst = '\\1000000'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result