#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(audio|image|video|x-(?:[0-9A-Za-z!#$%&'*+.^_`|~-]+))\/([0-9A-Za-z!#$%&'*+.^_`|~-]+)"
Local $sString = "audio/mpeg" & @CRLF & _
"audio/mp3" & @CRLF & _
"image/jpeg" & @CRLF & _
"image/png" & @CRLF & _
"application/zip" & @CRLF & _
"video/mp4" & @CRLF & _
"video/quicktime" & @CRLF & _
"video/webm" & @CRLF & _
"application/pdf" & @CRLF & _
"application/json; indent=4" & @CRLF & _
"application/json" & @CRLF & _
"text/*" & @CRLF & _
"*/*"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")