$re = '/(audio|image|video|x-(?:[0-9A-Za-z!#$%&\'*+.^_`|~-]+))\/([0-9A-Za-z!#$%&\'*+.^_`|~-]+)/';
$str = 'audio/mpeg
audio/mp3
image/jpeg
image/png
application/zip
video/mp4
video/quicktime
video/webm
application/pdf
application/json; indent=4
application/json
text/*
*/*';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);