// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(audio|image|video|x-(?:[0-9A-Za-z!#$%&'*+.^_`|~-]+))\/([0-9A-Za-z!#$%&'*+.^_`|~-]+)").unwrap();
let string = "audio/mpeg
audio/mp3
image/jpeg
image/png
application/zip
video/mp4
video/quicktime
video/webm
application/pdf
application/json; indent=4
application/json
text/*
*/*";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}