import re
regex = re.compile(r"(audio|image|video|x-(?:[0-9A-Za-z!#$%&'*+.^_`|~-]+))\/([0-9A-Za-z!#$%&'*+.^_`|~-]+)")
test_str = ("audio/mpeg\n"
"audio/mp3\n"
"image/jpeg\n"
"image/png\n"
"application/zip\n"
"video/mp4\n"
"video/quicktime\n"
"video/webm\n"
"application/pdf\n"
"application/json; indent=4\n"
"application/json\n"
"text/*\n"
"*/*")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")