const regex = /(audio|image|video|x-(?:[0-9A-Za-z!#$%&'*+.^_`|~-]+))\/([0-9A-Za-z!#$%&'*+.^_`|~-]+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(audio|image|video|x-(?:[0-9A-Za-z!#$%&\'*+.^_`|~-]+))\\\/([0-9A-Za-z!#$%&\'*+.^_`|~-]+)', 'g')
const str = `audio/mpeg
audio/mp3
image/jpeg
image/png
application/zip
video/mp4
video/quicktime
video/webm
application/pdf
application/json; indent=4
application/json
text/*
*/*`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}