import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(audio|image|video|x-(?:[0-9A-Za-z!#$%&'*+.^_`|~-]+))\\/([0-9A-Za-z!#$%&'*+.^_`|~-]+)";
final String string = "audio/mpeg\n"
+ "audio/mp3\n"
+ "image/jpeg\n"
+ "image/png\n"
+ "application/zip\n"
+ "video/mp4\n"
+ "video/quicktime\n"
+ "video/webm\n"
+ "application/pdf\n"
+ "application/json; indent=4\n"
+ "application/json\n"
+ "text/*\n"
+ "*/*";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}