using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bIndicative selling price.*?\$(\d{5,6})(?:.*?\$(\d{5,6}))?.*?Median sale price\b";
string input = @"Format 1
Indicative selling price
(*Delete single price or range as applicable)
Single price $ or range between $740000 & $760000
Median sale price
Format 2
Indicative selling price
(*Delete single price or range as applicable)
Single price $740000 or range between &
Median sale price
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}