package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)\bIndicative selling price.*?\$(\d{5,6})(?:.*?\$(\d{5,6}))?.*?Median sale price\b`)
var str = `Format 1
Indicative selling price
(*Delete single price or range as applicable)
Single price $ or range between $740000 & $760000
Median sale price
Format 2
Indicative selling price
(*Delete single price or range as applicable)
Single price $740000 or range between &
Median sale price
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}