# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\bIndicative selling price.*?\$(\d{5,6})(?:.*?\$(\d{5,6}))?.*?Median sale price\b"
test_str = ("Format 1\n\n"
"Indicative selling price\n\n"
"(*Delete single price or range as applicable)\n\n"
"Single price $ or range between $740000 & $760000\n\n"
"Median sale price\n\n"
"Format 2\n\n"
"Indicative selling price\n\n"
"(*Delete single price or range as applicable)\n\n"
"Single price $740000 or range between &\n\n"
"Median sale price\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.