import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bIndicative selling price.*?\\$(\\d{5,6})(?:.*?\\$(\\d{5,6}))?.*?Median sale price\\b";
final String string = "Format 1\n\n"
+ "Indicative selling price\n\n"
+ "(*Delete single price or range as applicable)\n\n"
+ "Single price $ or range between $740000 & $760000\n\n"
+ "Median sale price\n\n"
+ "Format 2\n\n"
+ "Indicative selling price\n\n"
+ "(*Delete single price or range as applicable)\n\n"
+ "Single price $740000 or range between &\n\n"
+ "Median sale price\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}