use strict;
my $str = 'Format 1
Indicative selling price
(*Delete single price or range as applicable)
Single price $ or range between $740000 & $760000
Median sale price
Format 2
Indicative selling price
(*Delete single price or range as applicable)
Single price $740000 or range between &
Median sale price
';
my $regex = qr/\bIndicative selling price.*?\$(\d{5,6})(?:.*?\$(\d{5,6}))?.*?Median sale price\b/msp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}