$re = '/\bIndicative selling price.*?\$(\d{5,6})(?:.*?\$(\d{5,6}))?.*?Median sale price\b/ms';
$str = 'Format 1
Indicative selling price
(*Delete single price or range as applicable)
Single price $ or range between $740000 & $760000
Median sale price
Format 2
Indicative selling price
(*Delete single price or range as applicable)
Single price $740000 or range between &
Median sale price
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);