# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^([^\r\n]*)\r?\n(?=.*^\1(?:\r?\n|\z))//gms;t' <<< "aaa
aaa
aaa
dsakjl dsa dlskj d aksdjkls djsa bbb
dsakjl dsa dlskj d aksdjkls djsa
bbb
aaa
dsakjl dsa dlskj d aksdjkls djsa
dsjakldj lsajkl dsa dslkjkj ldsa"