import re
regex = re.compile(r"^([^\r\n]*)\r?\n(?=.*^\1(?:\r?\n|\z))", flags=re.MULTILINE | re.DOTALL)
test_str = ("aaa\n"
"aaa\n"
"aaa\n"
"dsakjl dsa dlskj d aksdjkls djsa bbb\n\n"
"dsakjl dsa dlskj d aksdjkls djsa\n\n"
"bbb\n"
"aaa\n\n"
"dsakjl dsa dlskj d aksdjkls djsa\n"
"dsjakldj lsajkl dsa dslkjkj ldsa")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)