import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([^\\r\\n]*)\\r?\\n(?=.*^\\1(?:\\r?\\n|\\z))";
final String string = "aaa\n"
+ "aaa\n"
+ "aaa\n"
+ "dsakjl dsa dlskj d aksdjkls djsa bbb\n\n"
+ "dsakjl dsa dlskj d aksdjkls djsa\n\n"
+ "bbb\n"
+ "aaa\n\n"
+ "dsakjl dsa dlskj d aksdjkls djsa\n"
+ "dsjakldj lsajkl dsa dslkjkj ldsa";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}