$re = '/^([^\r\n]*)\r?\n(?=.*^\1(?:\r?\n|\z))/ms';
$str = 'aaa
aaa
aaa
dsakjl dsa dlskj d aksdjkls djsa bbb
dsakjl dsa dlskj d aksdjkls djsa
bbb
aaa
dsakjl dsa dlskj d aksdjkls djsa
dsjakldj lsajkl dsa dslkjkj ldsa';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;