using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?<=[\s,.:;""']|^)|\b)[0-9a-zа-яё]+(?:[.][0-9a-zа-яё]{2,})+(?:(?=[\s,.:;""']|$)|\b)";
string input = @"гугл.рус google.com jopa1.ru.com nick.name гугл.рус
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}