$re = '/(?:(?<=[\s,.:;"\']|^)|\b)[0-9a-zа-яё]+(?:[.][0-9a-zа-яё]{2,})+(?:(?=[\s,.:;"\']|$)|\b)/i';
$str = 'гугл.рус google.com jopa1.ru.com nick.name гугл.рус
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);