import re
regex = re.compile(r"(?:(?<=[\s,.:;\"']|^)|\b)[0-9a-zа-яё]+(?:[.][0-9a-zа-яё]{2,})+(?:(?=[\s,.:;\"']|$)|\b)", flags=re.IGNORECASE)
test_str = ("гугл.рус google.com jopa1.ru.com nick.name гугл.рус\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")