const regex = /(?:(?<=[\s,.:;"']|^)|\b)[0-9a-zа-яё]+(?:[.][0-9a-zа-яё]{2,})+(?:(?=[\s,.:;"']|$)|\b)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(?<=[\\s,.:;"\']|^)|\\b)[0-9a-zа-яё]+(?:[.][0-9a-zа-яё]{2,})+(?:(?=[\\s,.:;"\']|$)|\\b)', 'gi')
const str = `гугл.рус google.com jopa1.ru.com nick.name гугл.рус
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}