import Foundation
let pattern = #"(?:(?<=[\s,.:;"']|^)|\b)[0-9a-zа-яё]+(?:[.][0-9a-zа-яё]{2,})+(?:(?=[\s,.:;"']|$)|\b)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
гугл.рус google.com jopa1.ru.com nick.name гугл.рус
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)