#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[A-Z][A-Z]\d{3}\b\h+\S.*\s*(?>\RDate:\h+.*(?:\R(?!Date:|[A-Z][A-Z]\d{3}\b).*)*){2,}"
Local $sString = "UM001 Uddharana Madhava" & @CRLF & _
"" & @CRLF & _
"Date: 3/6/2021, Thursday" & @CRLF & _
"Topic: Bangla Economics" & @CRLF & _
"Language: Bengali" & @CRLF & _
"" & @CRLF & _
"Date: 4/6/2021, Friday" & @CRLF & _
"Topic: Bangla Economics" & @CRLF & _
"Language: Bengali" & @CRLF & _
"Additional info: Extra session" & @CRLF & _
"" & @CRLF & _
"Date: 3/6/2021, Thursday" & @CRLF & _
"Topic: Bangla Economics" & @CRLF & _
"Language: English" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"CJ009 Cidananda Janardana" & @CRLF & _
"" & @CRLF & _
"Date: 3/6/2021, Thursday" & @CRLF & _
"Topic: Bangla Economics" & @CRLF & _
"Language: Telugu" & @CRLF & _
"" & @CRLF & _
"VN019 Vrajanarayan " & @CRLF & _
"" & @CRLF & _
"Date: 4/6/2021, Friday" & @CRLF & _
"Topic: Bangla Economics" & @CRLF & _
"Language: Telugu" & @CRLF & _
"Course Type: Free" & @CRLF & _
"" & @CRLF & _
"Date: 5/6/2021, Saturday " & @CRLF & _
"Topic: Bangla Economics" & @CRLF & _
"Language: Telugu" & @CRLF & _
"" & @CRLF & _
"Date: 4/6/2021, Friday" & @CRLF & _
"Topic: Bangla Economics" & @CRLF & _
"Language: Bengali" & @CRLF & _
"" & @CRLF & _
"CJ009 Cidananda Janardana" & @CRLF & _
"" & @CRLF & _
"Date: 3/6/2021, Thursday" & @CRLF & _
"Topic: Bangla Economics" & @CRLF & _
"Language: Telugu" & @CRLF & _
"" & @CRLF & _
"CJ009 Cidananda Janardana" & @CRLF & _
"" & @CRLF & _
"Date: 3/6/2021, Thursday" & @CRLF & _
"Topic: Bangla Economics" & @CRLF & _
"Language: Telugu" & @CRLF & _
"" & @CRLF & _
"CJ009 Cidananda Janardana" & @CRLF & _
"" & @CRLF & _
"Date: 3/6/2021, Thursday" & @CRLF & _
"Topic: Bangla Economics" & @CRLF & _
"Language: Telugu" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")