use strict;
my $str = 'UM001 Uddharana Madhava
Date: 3/6/2021, Thursday
Topic: Bangla Economics
Language: Bengali
Date: 4/6/2021, Friday
Topic: Bangla Economics
Language: Bengali
Additional info: Extra session
Date: 3/6/2021, Thursday
Topic: Bangla Economics
Language: English
CJ009 Cidananda Janardana
Date: 3/6/2021, Thursday
Topic: Bangla Economics
Language: Telugu
VN019 Vrajanarayan
Date: 4/6/2021, Friday
Topic: Bangla Economics
Language: Telugu
Course Type: Free
Date: 5/6/2021, Saturday
Topic: Bangla Economics
Language: Telugu
Date: 4/6/2021, Friday
Topic: Bangla Economics
Language: Bengali
CJ009 Cidananda Janardana
Date: 3/6/2021, Thursday
Topic: Bangla Economics
Language: Telugu
CJ009 Cidananda Janardana
Date: 3/6/2021, Thursday
Topic: Bangla Economics
Language: Telugu
CJ009 Cidananda Janardana
Date: 3/6/2021, Thursday
Topic: Bangla Economics
Language: Telugu
';
my $regex = qr/^[A-Z][A-Z]\d{3}\b\h+\S.*\s*(?>\RDate:\h+.*(?:\R(?!Date:|[A-Z][A-Z]\d{3}\b).*)*){2,}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}