import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[A-Z][A-Z]\\d{3}\\b\\h+\\S.*\\s*(?>\\RDate:\\h+.*(?:\\R(?!Date:|[A-Z][A-Z]\\d{3}\\b).*)*){2,}";
final String string = "UM001 Uddharana Madhava\n\n"
+ "Date: 3/6/2021, Thursday\n"
+ "Topic: Bangla Economics\n"
+ "Language: Bengali\n\n"
+ "Date: 4/6/2021, Friday\n"
+ "Topic: Bangla Economics\n"
+ "Language: Bengali\n"
+ "Additional info: Extra session\n\n"
+ "Date: 3/6/2021, Thursday\n"
+ "Topic: Bangla Economics\n"
+ "Language: English\n\n\n"
+ "CJ009 Cidananda Janardana\n\n"
+ "Date: 3/6/2021, Thursday\n"
+ "Topic: Bangla Economics\n"
+ "Language: Telugu\n\n"
+ "VN019 Vrajanarayan \n\n"
+ "Date: 4/6/2021, Friday\n"
+ "Topic: Bangla Economics\n"
+ "Language: Telugu\n"
+ "Course Type: Free\n\n"
+ "Date: 5/6/2021, Saturday \n"
+ "Topic: Bangla Economics\n"
+ "Language: Telugu\n\n"
+ "Date: 4/6/2021, Friday\n"
+ "Topic: Bangla Economics\n"
+ "Language: Bengali\n\n"
+ "CJ009 Cidananda Janardana\n\n"
+ "Date: 3/6/2021, Thursday\n"
+ "Topic: Bangla Economics\n"
+ "Language: Telugu\n\n"
+ "CJ009 Cidananda Janardana\n\n"
+ "Date: 3/6/2021, Thursday\n"
+ "Topic: Bangla Economics\n"
+ "Language: Telugu\n\n"
+ "CJ009 Cidananda Janardana\n\n"
+ "Date: 3/6/2021, Thursday\n"
+ "Topic: Bangla Economics\n"
+ "Language: Telugu\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}