import re
regex = re.compile(r"^[A-Z][A-Z]\d{3}\b\h+\S.*\s*(?>\RDate:\h+.*(?:\R(?!Date:|[A-Z][A-Z]\d{3}\b).*)*){2,}", flags=re.MULTILINE)
test_str = ("UM001 Uddharana Madhava\n\n"
"Date: 3/6/2021, Thursday\n"
"Topic: Bangla Economics\n"
"Language: Bengali\n\n"
"Date: 4/6/2021, Friday\n"
"Topic: Bangla Economics\n"
"Language: Bengali\n"
"Additional info: Extra session\n\n"
"Date: 3/6/2021, Thursday\n"
"Topic: Bangla Economics\n"
"Language: English\n\n\n"
"CJ009 Cidananda Janardana\n\n"
"Date: 3/6/2021, Thursday\n"
"Topic: Bangla Economics\n"
"Language: Telugu\n\n"
"VN019 Vrajanarayan \n\n"
"Date: 4/6/2021, Friday\n"
"Topic: Bangla Economics\n"
"Language: Telugu\n"
"Course Type: Free\n\n"
"Date: 5/6/2021, Saturday \n"
"Topic: Bangla Economics\n"
"Language: Telugu\n\n"
"Date: 4/6/2021, Friday\n"
"Topic: Bangla Economics\n"
"Language: Bengali\n\n"
"CJ009 Cidananda Janardana\n\n"
"Date: 3/6/2021, Thursday\n"
"Topic: Bangla Economics\n"
"Language: Telugu\n\n"
"CJ009 Cidananda Janardana\n\n"
"Date: 3/6/2021, Thursday\n"
"Topic: Bangla Economics\n"
"Language: Telugu\n\n"
"CJ009 Cidananda Janardana\n\n"
"Date: 3/6/2021, Thursday\n"
"Topic: Bangla Economics\n"
"Language: Telugu\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")