$re = '/^[A-Z][A-Z]\d{3}\b\h+\S.*\s*(?>\RDate:\h+.*(?:\R(?!Date:|[A-Z][A-Z]\d{3}\b).*)*){2,}/m';
$str = 'UM001 Uddharana Madhava
Date: 3/6/2021, Thursday
Topic: Bangla Economics
Language: Bengali
Date: 4/6/2021, Friday
Topic: Bangla Economics
Language: Bengali
Additional info: Extra session
Date: 3/6/2021, Thursday
Topic: Bangla Economics
Language: English
CJ009 Cidananda Janardana
Date: 3/6/2021, Thursday
Topic: Bangla Economics
Language: Telugu
VN019 Vrajanarayan
Date: 4/6/2021, Friday
Topic: Bangla Economics
Language: Telugu
Course Type: Free
Date: 5/6/2021, Saturday
Topic: Bangla Economics
Language: Telugu
Date: 4/6/2021, Friday
Topic: Bangla Economics
Language: Bengali
CJ009 Cidananda Janardana
Date: 3/6/2021, Thursday
Topic: Bangla Economics
Language: Telugu
CJ009 Cidananda Janardana
Date: 3/6/2021, Thursday
Topic: Bangla Economics
Language: Telugu
CJ009 Cidananda Janardana
Date: 3/6/2021, Thursday
Topic: Bangla Economics
Language: Telugu
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);