# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/Local +(\w+) *\[\] *= *\[([^\[\]]+)\]/int[] $1 = new int[]\{$2\}\;/gm;t' <<< "Local v[]=[x1-x2,y1-y2]
Local v []=[x1-x2,y1-y2]
Local v[] = [x1-x2,y1-y2]
Local lklkk[]=[x1-x2, y1-y2 ]"