# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"Local +(\w+) *\[\] *= *\[([^\[\]]+)\]"
test_str = ("Local v[]=[x1-x2,y1-y2]\n"
"Local v []=[x1-x2,y1-y2]\n"
"Local v[] = [x1-x2,y1-y2]\n"
"Local lklkk[]=[x1-x2, y1-y2 ]")
subst = "int[] $1 = new int[]\\{$2\\}\\;"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.