import Foundation
let pattern = #"Local +(\w+) *\[\] *= *\[([^\[\]]+)\]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Local v[]=[x1-x2,y1-y2]
Local v []=[x1-x2,y1-y2]
Local v[] = [x1-x2,y1-y2]
Local lklkk[]=[x1-x2, y1-y2 ]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"int[] $1 = new int[]\{$2\}\;"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)