$re = '/Local +(\w+) *\[\] *= *\[([^\[\]]+)\]/m';
$str = 'Local v[]=[x1-x2,y1-y2]
Local v []=[x1-x2,y1-y2]
Local v[] = [x1-x2,y1-y2]
Local lklkk[]=[x1-x2, y1-y2 ]';
$subst = "int[] $1 = new int[]\{$2\}\;";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;