import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Local +(\\w+) *\\[\\] *= *\\[([^\\[\\]]+)\\]";
final String string = "Local v[]=[x1-x2,y1-y2]\n"
+ "Local v []=[x1-x2,y1-y2]\n"
+ "Local v[] = [x1-x2,y1-y2]\n"
+ "Local lklkk[]=[x1-x2, y1-y2 ]";
final String subst = "int[] $1 = new int[]\\{$2\\}\\;";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}