// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)Local +(\w+) *\[\] *= *\[([^\[\]]+)\]").unwrap();
let string = "Local v[]=[x1-x2,y1-y2]
Local v []=[x1-x2,y1-y2]
Local v[] = [x1-x2,y1-y2]
Local lklkk[]=[x1-x2, y1-y2 ]";
let substitution = "int[] $1 = new int[]\\{$2\\}\\;";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}