package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)/([^/]+)/`)
var str = `p pen /pen/
b bad /bæd/
t tea /tiː/`
var substitution = "[$1]"
fmt.Println(re.ReplaceAllString(str, substitution))
}