re = /\/([^\/]+)\//m
str = 'p pen /pen/
b bad /bæd/
t tea /tiː/'
subst = '[$1]'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result