// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)/([^/]+)/").unwrap();
let string = "p pen /pen/
b bad /bæd/
t tea /tiː/";
let substitution = "[$1]";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}