#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\d+\.\d+?$"
Local $sString = "TP1 BCArc 156.2" & @CRLF & _
"TP2 Max: of output here 0.01" & @CRLF & _
"TP3 some:other example 1 here 30.70" & @CRLF & _
"TP1 BCArc 30" & @CRLF & _
"TP2 Max: of output here 2.22"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")