package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d+\.\d+?$`)
var str = `TP1 BCArc 156.2
TP2 Max: of output here 0.01
TP3 some:other example 1 here 30.70
TP1 BCArc 30
TP2 Max: of output here 2.22`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}