re = /\d+\.\d+?$/
str = 'TP1 BCArc 156.2
TP2 Max: of output here 0.01
TP3 some:other example 1 here 30.70
TP1 BCArc 30
TP2 Max: of output here 2.22'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end