const regex = /\d+\.\d+?$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d+\\.\\d+?$', 'g')
const str = `TP1 BCArc 156.2
TP2 Max: of output here 0.01
TP3 some:other example 1 here 30.70
TP1 BCArc 30
TP2 Max: of output here 2.22`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}