import re
regex = re.compile(r"\d+\.\d+?$")
test_str = ("TP1 BCArc 156.2\n"
"TP2 Max: of output here 0.01\n"
"TP3 some:other example 1 here 30.70\n"
"TP1 BCArc 30\n"
"TP2 Max: of output here 2.22")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")