using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\""LogDate\"":\s+\""(?<LogDate>[^\""]+)";
string input = @"{ [-]
event: INFO 2022-09-23 11:49:59,033 [[MuleRuntime].uber.01: [papi-ust-email-notification-v1-uw-qa].get:\ping:Router.CPU_LITE @6c1fb7] org.mule.runtime.core.internal.processor.LoggerMessageProcessor: {
""LogDate"": ""09/23/2022 16:11:13.932"",
""LogNo"": ""99"",
""LogLevel"": ""INFO"",
""LogType"": ""Process Level"",
""LogMessage"": ""Splunk anypoint log"",
""TimeTaken"": ""0:00:12.628"",
""ProcessName"": ""AnypointSplunkTest"",
""TaskName"": ""AnypointTest"",
""RPAEnvironment"": ""DEV"",
""LogId"": ""002308900.20250824210419999"",
""MachineName"": ""abc-xyz-efg"",
""User"": ""name.first""
}
metaData: { [+]
}
}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}