import Foundation
let pattern = #"\"LogDate\":\s+\"(?<LogDate>[^\"]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
{ [-]
event: INFO 2022-09-23 11:49:59,033 [[MuleRuntime].uber.01: [papi-ust-email-notification-v1-uw-qa].get:\ping:Router.CPU_LITE @6c1fb7] org.mule.runtime.core.internal.processor.LoggerMessageProcessor: {
"LogDate": "09/23/2022 16:11:13.932",
"LogNo": "99",
"LogLevel": "INFO",
"LogType": "Process Level",
"LogMessage": "Splunk anypoint log",
"TimeTaken": "0:00:12.628",
"ProcessName": "AnypointSplunkTest",
"TaskName": "AnypointTest",
"RPAEnvironment": "DEV",
"LogId": "002308900.20250824210419999",
"MachineName": "abc-xyz-efg",
"User": "name.first"
}
metaData: { [+]
}
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)