# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\"LogDate\":\s+\"(?<LogDate>[^\"]+)"
test_str = ("{ [-]\n"
" event: INFO 2022-09-23 11:49:59,033 [[MuleRuntime].uber.01: [papi-ust-email-notification-v1-uw-qa].get:\\ping:Router.CPU_LITE @6c1fb7] org.mule.runtime.core.internal.processor.LoggerMessageProcessor: {\n"
" \"LogDate\": \"09/23/2022 16:11:13.932\",\n"
" \"LogNo\": \"99\",\n"
" \"LogLevel\": \"INFO\",\n"
" \"LogType\": \"Process Level\",\n"
" \"LogMessage\": \"Splunk anypoint log\",\n"
" \"TimeTaken\": \"0:00:12.628\",\n"
" \"ProcessName\": \"AnypointSplunkTest\",\n"
" \"TaskName\": \"AnypointTest\",\n"
" \"RPAEnvironment\": \"DEV\",\n"
" \"LogId\": \"002308900.20250824210419999\",\n"
" \"MachineName\": \"abc-xyz-efg\",\n"
" \"User\": \"name.first\"\n"
"}\n"
" metaData: { [+]\n"
" }\n"
"}")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.