import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\\"LogDate\\\":\\s+\\\"(?<LogDate>[^\\\"]+)";
final String string = "{ [-]\n"
+ " event: INFO 2022-09-23 11:49:59,033 [[MuleRuntime].uber.01: [papi-ust-email-notification-v1-uw-qa].get:\\ping:Router.CPU_LITE @6c1fb7] org.mule.runtime.core.internal.processor.LoggerMessageProcessor: {\n"
+ " \"LogDate\": \"09/23/2022 16:11:13.932\",\n"
+ " \"LogNo\": \"99\",\n"
+ " \"LogLevel\": \"INFO\",\n"
+ " \"LogType\": \"Process Level\",\n"
+ " \"LogMessage\": \"Splunk anypoint log\",\n"
+ " \"TimeTaken\": \"0:00:12.628\",\n"
+ " \"ProcessName\": \"AnypointSplunkTest\",\n"
+ " \"TaskName\": \"AnypointTest\",\n"
+ " \"RPAEnvironment\": \"DEV\",\n"
+ " \"LogId\": \"002308900.20250824210419999\",\n"
+ " \"MachineName\": \"abc-xyz-efg\",\n"
+ " \"User\": \"name.first\"\n"
+ "}\n"
+ " metaData: { [+]\n"
+ " }\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}