use strict;
my $str = '{ [-]
event: INFO 2022-09-23 11:49:59,033 [[MuleRuntime].uber.01: [papi-ust-email-notification-v1-uw-qa].get:\\ping:Router.CPU_LITE @6c1fb7] org.mule.runtime.core.internal.processor.LoggerMessageProcessor: {
"LogDate": "09/23/2022 16:11:13.932",
"LogNo": "99",
"LogLevel": "INFO",
"LogType": "Process Level",
"LogMessage": "Splunk anypoint log",
"TimeTaken": "0:00:12.628",
"ProcessName": "AnypointSplunkTest",
"TaskName": "AnypointTest",
"RPAEnvironment": "DEV",
"LogId": "002308900.20250824210419999",
"MachineName": "abc-xyz-efg",
"User": "name.first"
}
metaData: { [+]
}
}';
my $regex = qr/\"LogDate\":\s+\"(?<LogDate>[^\"]+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}