#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?i)^(?:https?:\/\/)?(?:www\.)?(?:[a-z0-9-]+\.){1,9}[a-z]{2,5}(?:\/.*)?$"
Local $sString = "www.google.com" & @CRLF & _
"google.com" & @CRLF & _
"drive.google.com" & @CRLF & _
"http://www.google.com" & @CRLF & _
"http://google.com" & @CRLF & _
"http://drive.google.com" & @CRLF & _
"https://www.google.com" & @CRLF & _
"https://www.google.com" & @CRLF & _
"https://www.drive.google.com" & @CRLF & _
"https://www.google.com/some_other_things" & @CRLF & _
"https://www.google.com/" & @CRLF & _
"https://www.drive.google.com/" & @CRLF & _
"https://www.a.a.a.a.a.a.a.a.a.google.com/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")